Изменения в Selenide 2.21 и 2.22

Вышла Selenide 4.4.1

Блог

Изменения в Selenide 2.21 и 2.22

Java 7, Selenium 2.47.1

Доброй субботы!

Недавно мы зарелизили Selenide 2.21 и 2.22. Там были немногочисленные, но кардинальные изменения, о которых вам нужно знать.

Переход на Java 7

Начиная с версии 2.21, Selenide работает только на Java 7 или выше.

Если вы до сих пор работали на Java 6, пора обновляться - больше ждать невозможно!

Обновились на Selenium 2.47.1

  • Она-то и требует Java 7.
  • поддержка нативных событий только до FireFox 31, а для более новых FireFox есть только синтетические события.
  • Добавилась экспериментальная поддержка нового браузера “Microsoft Edge”

Список изменений 2.47.1

Исправлена проблема с незакрывающимися браузерами

В версии Selenide 2.20 изменился механизм закрытия браузеров. Появился неприятный эффект, когда некоторые браузеры оставались незакрытыми. Проблему оперативно залечили.



Спасибо за вашу помощь!

Спасибо всем, кто проголосовал. Ваши голоса помогли, и мою заявку приняли на конференцию SeleniumConf 2015. Еду 8 сентября в Портланд рассказывать про Selenide американской аудитории.

Новости

Хочу поделиться новостями


А что у вас новенького?


Андрей Солнцев

ru.selenide.org

blog comments powered by Disqus

The project is maintained by